Troubleshooting The Stepper Motor Drivers V2 3

Symptom: Your stepper motors are unresponsive. When you go into the control panel, one or more of them do not respond.

  1. Restart ReplicatorG. Make sure that it indicates that it has connected to the bot.
  2. Open the control panel and press then "enable steppers" and "disable steppers" buttons. Watch the stepper drivers. If green and red lights turn on when you press "enable" and off when you press "disable", the problem is probably related to the endstops.
    1. If you are using the v2 firmware or later, open the "Machine>Onboard Preferences" menu. Select the correct endstop type (or "No endstops") for your machine. Click "commit", and then reset your bot.
    2. Make sure that the endstops on the axis you're using are not triggered.
  3. If the lights do not light up, the problem may be related to the connection between the motherboard and the stepper driver.
    1. Visually examine your cords and cables. Are plugs are attached and seated snugly? Each Stepper Driver should be connected from the socket marked INTERFACE on the Stepper Motor Driver board to the sockets on the Motherboard labeled X AXIS,Y AXIS, and Z AXIS respectively with a rainbow ribbon cable. The Power cords from the corresponding axis' motor should be connected to the socket on each board labeled ABCD. And the main power from the PSU should be connected from the large narrow socket with "Stepper Motor Driver" written above it.
    2. Examine the rainbow ribbon cables, power cords, and motor cables.
      • Are the connectors on both ends attached the same way? When you hold the connector on either end with the alignment tab facing up, are the colors on the cable in the same sequence?
      • Do they seem damaged, or are the heads loose?
      • Is there any visible wear, exposed/melted wiring, or discoloration around the plugs heads?
      • The number one problem people have with stepper motor response is they have either put their rainbow cables together wrong or they look right but there are connections missing. Replacing the rainbow cables solves most problems.
  4. Start alternating the connections on the Stepper Motor Board. If you have one axis which is giving you trouble, try switching in the cables and cords from an axis that is working, and try triggering the stepper Motor with those parts connected. Continue alternating the available cables until you identify in what combination the part fails. This process of elimination can help identify a bad cable, motor, or board in not much time.
  5. Visually inspect the Stepper Motor Driver PCB. Remove the attached cords and cables, loosen and remove the hex nuts. Once you can take the board off the botcase, look at it under some bright light. If you have a magnifying glass or loop, get it and start examining the boards. Look for solder bridges, discolorations, missing or broken solder joints, burnt chips, or any other visible abnormality. Examine the SMD solder joints on the pins of the chips for solder bridges.
  6. If you see any unsoldered joints, you can try soldering them yourself. If you see joints that look strange or discolored, too small or uneven, that could be a problem. Carefully reheat and melt the solder, or add more solder to close any gaps. You may want to push the item you are soldering to seat it better while you solder the joint on the other side.
    • This is a known problem and an unfortunate consequence of soldering, sometimes solderjoints fail or there are "bridges." Finding and fixing solder joints and bridges has saved many boards from the garbage pile!
  7. Try upgrading the firmware to the latest version, if you haven't already.
Unless otherwise stated, the content of this page is licensed under GNU Free Documentation License.